目录

prefer_generic_function_type_aliases

Prefer generic function type aliases.

此规则自 Dart 2.0 版本起可用。

_规则集:core , recommended , flutter _

此规则提供 快速修复

详情

#

PREFER generic function type aliases.

With the introduction of generic functions, function type aliases (typedef void F()) couldn't express all of the possible kinds of parameterization that users might want to express. Generic function type aliases (typedef F = void Function()) fixed that issue.

For consistency and readability reasons, it's better to only use one syntax and thus prefer generic function type aliases.

BAD:

dart
typedef void F();

GOOD:

dart
typedef F = void Function();

使用方法

#

要启用 prefer_generic_function_type_aliases 规则,请在你的 analysis_options.yaml 文件中,在 linter > rules 下添加 prefer_generic_function_type_aliases

analysis_options.yaml
yaml
linter:
  rules:
    - prefer_generic_function_type_aliases